Suite

Mise à niveau vers la géodatabase ArcGIS 10.3 sur Windows R2 SP2 et Oracle 10g (64 bits) 10.2.0.5 ?


Nous avons Oracle 10g (64 bits) 10.2.0.5 sur Windows Server 2008 Enterprise SP2, et nous prévoyons de migrer notre géodatabase de 9.3.1 à 10.3.

Selon Esri "Oracle Database Requirements for ArcGIS 10.3.x", le système d'exploitation maximal est SP1.

Est-ce que quelqu'un sait ce qu'est la limitation/le risque/les impacts si nous gardons notre OS SP2 et non SP1 et migrons notre géodatabase ?

Et si nous migrions notre ArcGIS Server/Desktop vers 10.3 et continuions à utiliser la géodatabase 9.3.1 ?


Vous avez mal interprété la signification des pages d'environnement pris en charge. Esri jamais spécifie un "OS maximum". Il ne fait que rapporter testé et certifié configuration. Les configurations plus anciennes ne sont pas prises en charge, et pour les plus récentes, la politique d'environnement pris en charge indique :

Cet environnement est pris en charge s'il respecte ou dépasse l'environnement de génération de base et que cet environnement est connu pour ne pas échouer.

Votre risque est d'utiliser un ancien système d'exploitation, avec une ancienne installation d'Oracle, avec d'anciens composants Java, très probablement sur du matériel ancien. Chacune de ces choses est individuellement beaucoup plus dangereuse pour votre infrastructure que d'utiliser SP2 sur SP1 sur un système d'exploitation qui nécessite déjà un paiement supplémentaire pour les mises à jour des correctifs de sécurité.

Vous ne pouvez pas laisser votre géodatabase à 9.3.1, car les géodatabases 9.3.1 ne sont pas prises en charge avec ArcGIS 10.3 ("se connecter uniquement pour mettre à niveau").

ArcGIS 10.3 nécessite déjà un client Oracle 11g ou 12c pour se connecter aux bases de données 10gR2 ; vous devriez commencer à vous préparer pour le jour où Oracle 10gR2 ne sera pas du tout pris en charge.