Suite

L'utilisation de LAStools dans QGIS donne « le nom global 'os' n'est pas défini » ?


J'ai un problème avec LAStools dans QGIS 2.6.1. Je n'ai jamais utilisé QGIS pour traiter des données LiDAR auparavant.

J'ai téléchargé LAStools hier sur le site Web de rapidlasso GmbH. J'ai décompressé le fichier "lastools.zip" dans mon dossier osgeo (C:OSGeo4W64LAStools) et j'ai suivi les instructions pour activer LAStools et spécifier l'emplacement du dossier. LAStools apparaît correctement dans ma boîte à outils de traitement dans QGIS.

Ensuite, j'ai téléchargé une tuile LiDAR du National Land Survey of Finland sous forme de fichier .laz. J'ai essayé d'utiliser lasground pour afficher ces données et j'ai suivi les instructions sur le site Web de rapidlasso GmbH (voir capture d'écran). Cependant, j'obtiens ce message dans mon log :

Algorithme lasground démarrant… le nom global 'os' n'est pas défini Voir le journal pour plus de détails

Me manque-t-il une dépendance de ma bibliothèque ?


Mon problème était qu'il y avait un espace dans le chemin d'accès au fichier .las que j'utilisais.


J'ai suivi les instructions contenues dans le fichier README.txt de la dernière version de lastools, un fichier zip téléchargeable à partir de ce lien : http://lastools.org/download/lastools.zip. Extrayez le fichier zip dans n'importe quel dossier sans espaces dans le chemin. Ouvrez le dossier QGIS_toolbox où se trouve le fichier README.txt. Ouvrez ce fichier et suivez les instructions de la ligne numéro 24. J'ai QGIS 2.6.1 installé sur Windows 7 et lastools fonctionne bien. Pour l'instant, j'ai essayé uniquement l'algorithme lasview.


J'ai aussi headbangé et j'ai au moins une solution partielle. Sur un Mac, allez dans Traitement puis Options mais NE CLIQUEZ PAS sur activer. Cliquez (ou peut-être faites un clic droit) sur l'espace blanc à droite de l'icône du dossier, appuyez sur le bouton droit à 3 points sur le côté droit, puis accédez aux applications et sélectionnez QGIS.

Appuyez ensuite sur le bouton d'activation.

Je peux ensuite ouvrir un projet LASTools avec un menu de saisie que je n'ai pas encore essayé, mais ces étapes suppriment le "dossier LASTools n'est pas configuré" que l'on obtient autrement. J'ai cliqué ou fait un clic droit sur le projet LASTools dans la fenêtre pour activer la fenêtre d'initiation.


Voir la vidéo: Generate a DSM from a point cloud in QGIS using the LASTools plugin (Septembre 2021).