Suite

GeoServer 2.7.1 ne démarre pas après l'installation de l'extension de script 11-Aug-2015


Ce problème ne semble pas être spécifique à la version pour moi. J'ai essayé plusieurs fois avec différentes versions et différentes configurations de système. Comme le titre l'indique, lorsque j'ajoute l'extension de script à GeoServer, elle cesse de fonctionner. Aucune suggestion? Je l'exécute sur Debian 8.

Voici un extrait de data/logs/geoserver.log :

2015-08-12 11:52:31,066 WARN [support.DisposableBeanAdapter] - L'appel de la méthode destroy a échoué sur le bean avec le nom 'geoServerLoader': java.lang.NullPointerException

2015-08-12 11:52:31,067 ERROR [context.ContextLoader] - L'initialisation du contexte a échoué /tomcat8/webapps/geoserver-test/WEB-INF/lib/gs-wcs-2.7.1.jar!/applicationContext.xml] : impossible de résoudre la référence au bean 'catalog' lors de la définition de l'argument du constructeur ; l'exception imbriquée est org.springframework.beans.factory.BeanCreationException : erreur lors de la création du bean avec le nom 'localWorkspaceCatalog' défini dans l'URL [jar:file:/var/lib/tomcat8/webapps/geoserver-test/WEB-INF/lib/gs- main-2.7.1.jar!/applicationContext.xml] : impossible de résoudre la référence au bean 'advertisedCatalog' lors de la définition de l'argument du constructeur ; l'exception imbriquée est org.springframework.beans.factory.BeanCreationException : erreur lors de la création du bean avec le nom "advertisedCatalog" défini dans l'URL [jar:file:/var/lib/tomcat8/webapps/geoserver-test/WEB-INF/lib/gs- main-2.7.1.jar!/applicationContext.xml] : impossible de résoudre la référence au bean 'secureCatalog' lors de la définition de l'argument du constructeur ; l'exception imbriquée est org.springframework.beans.factory.BeanCreationException : erreur lors de la création du bean avec le nom "secureCatalog" défini dans l'URL [jar:file:/var/lib/tomcat8/webapps/geoserver-test/WEB-INF/lib/gs- main-2.7.1.jar!/applicationContext.xml] : l'instanciation du bean a échoué ; l'exception imbriquée est org.springframework.beans.BeanInstantiationException : impossible d'instancier la classe de bean [org.geoserver.security.SecureCatalogImpl] : le constructeur a lancé une exception ; L'exception imbriquée est java.lang.NullPointerException à org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:329)…


L'extension de script Python fonctionne avec la version 2.4 du 20 août 2014, en particulier cette version de GeoServer avec cette version du plugin Python.