Suite

Message de l'éditeur ArcMap 10.3.1 : « Une couche pour PROJECT_LINES n'a pas été trouvée… »


Lors de la modification d'une classe d'entités stockée dans Oracle Spatial, je reçois 3 messages d'avertissement lors de l'arrêt de la session de mise à jour :

Il y en a 2 autres après avoir appuyé sur OK - PROJET_POINTS et PROJET_POLYGONES.

Je voulais voir si cela se produirait dans une géodatabase fichier et un fichier de formes, alors j'ai enregistré des copies des données d'origine dans ces formats et j'ai essayé de démarrer puis d'arrêter l'édition. Le FGDB affiche les mêmes messages que ci-dessus, contrairement au SHP.

Est-ce que quelqu'un a déjà vu ces messages et peut me les expliquer ou me diriger vers plus d'informations à leur sujet. J'aimerais résoudre entièrement le problème, mais les données semblent conserver une référence même après l'enregistrement en tant que nouveau fichier.

Mise à jour 1 : J'ai contacté le support esri. Si je trouve une réponse à travers eux, je la partagerai ici, mais ils semblent également déconcertés par cela.


J'ai décidé de créer les classes d'entités PROJECT_POINTS, *_LINES et *_POLYGONS dans l'une des GDB pour voir si je recevrais les mêmes messages d'avertissement. Je les ai ajoutés à un MXD propre avec le fichier des autoroutes de la base de données d'origine qui lançait les messages d'avertissement. J'ai commencé une session d'édition puis arrêté comme avant. Cette fois, j'ai reçu un nouveau message indiquant que je devais renommer les nouveaux calques. Lorsque je les ai renommés pour qu'ils correspondent au nouveau message et que j'ai réessayé, j'ai pu démarrer et arrêter une session d'édition sans messages d'avertissement.

Après quelques discussions à ce sujet, nous avons décidé que cela pourrait avoir quelque chose à voir avec notre mise à niveau de 10.1 à 10.3.1. Nous avons une machine qui n'a pas été mise à jour et avons découvert qu'il y avait un complément personnalisé qui a été construit pour 10.0 et qui fonctionnait toujours dans 10.1. Nous avons pu retracer le problème jusqu'à ce complément et une fois que j'ai supprimé la référence à celui-ci dans mon éditeur de registre, tout a fonctionné comme il se doit.


Voir la vidéo: A Complete Beginners Guide to ArcGIS Desktop Part 1 (Octobre 2021).